wiki:Archer/cce8.3.7

Version 17 (modified by ros, 4 years ago) (diff)

As part the regular software upgrade cycle, ARCHER will remove the Cray cce8.2.1 compiler on June 24th. cce8.2.1 has been the UM compiler since ARCHER became operational and we have maintained its use to minimize possible disruption but it does appear to be a source of OOM errors in some long-running UM jobs. These OOM errors have not appeared in jobs running code compiled with later Cray compilers, so it is timely to upgrade to the current ARCHER default - cce8.3.7.

cce8.3.7 GCOMs (gcom3.8 gcom4.2 gcom4.5 gcom4.6 gcom4.7 gcom5.1) are in $UMDIR/gcom/cce8.3.7

Include MPICH_NO_BUFFER_ALIAS_CHECK=1

Compiler upgrade notes

UM Version Description cce8.3.7 jobid cce8.2.1 jobid Comments
8.2 N96 HadGEM3A xlnia xleha Needed to reduce optimization on convection to O1 - didn't look for specific routine - only checked with 1 start file
8.2 N512 - the SWAMMA driving model xjjzv xjjzw OOM errors seen (see ticket #1535); worked as is
8.2 12km SWAMMA xlnib xlehb OOM errors in the cce8.2.1 job; worked as is
8.4 N96 GA? xjfvy xlchx OOM errors in the cce8.2.1 job; needed fix for bug in locate_hdps.F90 - had to cast array indices to INTS - change added to the ncas branch see ticket #1485
6.6.3 HadGEM2-AMIP xlnic xjgcc runs OK built with -g - blows up somewhere with 8.2.1 settings — large_scale_cloud::ls_arcld is the culprit; build this with -O0 and the model runs OK
6.6.3 HadGEM2-ES xlnid xjgcu worked as is
6.6.3 HadGEM2-CC xlnie xjgcf needs large_scale_cloud::ls_arcld compiled with -O0 and the model runs OK
7.3 HadGEM3-A r2.0 xlnif xjeya worked as is
8.6 HG3A GA6.0 xloba xjvpu No modifications required